XF Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
I can't see if anyone else has posted on anything similar but would appreciate any thoughts or comments if you've had any similar experience.

The 2009-10 DVD has been installed for about a year and I've used the sat nav without issue in all that time but the other night it started playing up.

it started with all the roads disappearing from the map image then freezing up, occasionally re-starting OK and occasionally going completely blank then showing a DVD disk error message. After a few minutes it would re-start, pick up my original journey but then follow a similar pattern seeminlgy taking longer to get over itself each time.

The next morning (equipped with paper route maps as back up) it was a bit hesitant to let me put the postcode in but then got me from Stevenage to Norwich then Norwich to Chelmsford without any trouble then only once showing the error between Chelmsford and Gloucester.

Has anyone else had anything similar? It could be a one off glitch in the matrix and having rested the car over the weekend it might be fine but my concernd is that there's a bigger problem developing.
 

·
Registered
Joined
·
248 Posts
Have you tried putting one of the other country DVDs in and trying them?

The laser could be dirty or failing. Try a DVD cleaning CD.

Also, I once had water leak in on the sat nav in my old MG ZTT and that sent the whole car loopy with the doors unlocking, the alarm going off & wipers kept starting.
 

·
Registered
Joined
·
52 Posts
This sounds familiar. The erratic behavour you describe is similar to that I experienced on my previous car, a 2007 M-B E280CDi. The cause was traced to water leaking through a grommet hole in the drain channel of the boot aperature. This dripped onto the Sat-Nav hard drive located in the left side of the boot. The hard drive and disc were replaced under warranty, along with the offending grommet and all was well. I'd recommend you let your dealer take a look. Let us know how you get on.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Wow - I can't believe I posted this back in June as it has only just got fixed but fair play to Jaguar it was done under warranty eventually.

They had it in a few times then concluded it was a problem with the DVD disk which I couldn't believe as it was a brand new disk put in last year and hadn't been taken out before it started going wrong. The dealer then lent me a disk which seemed OK for a week or two but then started doing exactly the same and other bizarre symptoms such as completely resetting the systen by itself or showing a compass as it couldn't show a map.

In the end the Sat Nav control unit was replaced last week (worth £1500 apparnetly) and so far, so good!
 
1 - 4 of 4 Posts
Top