XF Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So it’s too late to turn back as I paid my deposit for a 25k miles 2015 XF R-Sport Black in a beautiful red at the weekend and now excitedly awaiting delivery. What should I be looking for on final collection day (other than chips and scratches)?
Also why is everything expensive (my previous Mazda 6 tourer, roof bar fittings are simple and a tow bar was £395) but I need two sets of feet for my Thule roof bars and a tow bar is £580 for fixed and £700 for detachable☹
Not moaning though because the Jag looks truly stunning.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I’ll post a pic when I get the car back after only a couple days driving discovered an issue - the start stop doesn’t work and the notice on starting is the battery is low and system will shut down in either 1 or 3 minutes - I’ve checked the batteries and they are both healthy at over 12v and increase by 2v when the car is running so seems like just the BMS needs resetting. The Ford dealer I bought it from wants to charge up overnight though before they try anything else.
 

·
Registered
Joined
·
332 Posts
Welcome. :)
I’ve checked the batteries and they are both healthy at over 12v
I think you'll find your batteries either need a good charge (take the car for a good run or use a smart charger) or replacement. Under 13v is too low when the engine is not running.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Thanks - the garage charged it and think it’s now okay so will be collecting tomorrow, still think there may be an issue because I drove 300 miles at the weekend and that wasn’t enough to solve it so the overnight charge may only be a temporary solution.
 

·
Registered
Joined
·
1 Posts
Our 2014 XF 2.2D started having electrical troubles about 2 years ago. Still on original Varta AGM battery. The start stop stopped working, then recurrent messages about "low battery - start motor or shut down", then the dash air vents refused to close, then the interior lights would extinguish after about 10 seconds of opening a door.
The car started fine, though, summer or winter, so I didn't pay much attention. Too busy with other things, although I did put the batteries on charge a couple of times. This didn't do anything to help the problems.
Last month, I noticed that the starter motor sounded slightly sluggish, so I bought a replacement main battery. Finally, all the electrics are working as intended again!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Thanks for your suggestions, and after 4 visits to the dealer they came up with the same solution and have replaced the main battery and now everything is spot on. It is such a nice car to drive, a real upgrade from my Mazda 6 (which itself was never a bad car). This is it...
Wheel Tire Car Vehicle Holden commodore
 
1 - 8 of 8 Posts
Top