XF Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Just recently I have had a problem with my sat nav on longer journeys.

It it is fine for about an hour, works as it should, but sometimes, after an hour and especially if I don't follow the exact route, it 'loses the route'. When I re enter the route (when the fault occurs the sat nav also really slows down....I have to wait 10 or 20 seconds each time I press a button for it to react).

It never then allows me to enter another route.

If I stop, remove the disc and re enter it then there it is okay, or if the car is off for an hour (cooled down?)

i'm wondering if a new sat nav disc update would solve this, but don't want to buy one unless I know that will solve the problem. Has anyone else had this or a similar fault??

thanks, in advance.
 

·
Registered
Joined
·
210 Posts
Hi 1stJag

Your issue sounds really as a bug in the SW; any identification would need the version of the jag (MY…) or even such an id on the DVD disc.
I do have a MY2012, which has got a hd based system; although there are issues I've never experienced yours!
 

·
Registered
Joined
·
3,273 Posts
Like Michael.R said 1stjag, there is something wrong with the sat-nav. Could be that a software update helps but I guess you´ll have to book an appointment with your dealer/garage.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Hi 1stJag

Your issue sounds really as a bug in the SW; any identification would need the version of the jag (MY…) or even such an id on the DVD disc.
I do have a MY2012, which has got a hd based system; although there are issues I've never experienced yours!

Thanks michael, ale, what is the SW?

when you version of the jag do you mean the car or the sat nav system?

the car is an 08 plate 2.7.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Like Michael.R said 1stjag, there is something wrong with the sat-nav. Could be that a software update helps but I guess you´ll have to book an appointment with your dealer/garage.
Hi the German, thank you, yes I realise there is something wrong with my sat nav and yes I will book with my dealership, but for now I'm trying to find out if this is a common fault before I book it in.

Thanks.
 

·
Registered
Joined
·
1,930 Posts
Thanks michael, ale, what is the SW?

when you version of the jag do you mean the car or the sat nav system?

the car is an 08 plate 2.7.
SW means software. There are instructions to find out which version you have on here somewhere if you search for it. It does happen from time to time and the dealer often has a fix by upgrading the software which operates the satnav.
 

·
Registered
Joined
·
300 Posts
I have had two faults with my sat nav system GPS no signal dealer fitted new antenna four weeks later same fault only the car says it is in Germany going back into he dealers Thursday I I my 2013 model
 

·
Registered
Joined
·
14 Posts
Got my first jag xf S 3.0L diesel 2010 in oct and have found the sat nav to be completely useless .
great car but so many things let it down , saw 8.4 mpg recently best i have seen is 26 mpg ! where the hell do they get 47 mpg from, eats tyres and brakes faster than a superbike ! love it when the disk glow red !!! maybe i just drive it to hard ?
 
1 - 8 of 8 Posts
Top