XF Forum banner

1 - 3 of 3 Posts

Registered
Joined
2 Posts
Discussion Starter #1
Hi all, my son has bought an XF, love it! But he was away for 4 weeks. On his return the battery was flat. He got it jump started and went to Kwik fit where they put in a new battery and "reset" it. Our query is that, several times since then, the start/stop activates at the lights once he takes his foot off his brake pedal it goes into park and turns off! Any ideas how to stop this please??
 

Registered
Joined
2,560 Posts
Hi, welcome to the forum.

Remember, first rule of this forum is car show of 馃榿 what year/engine/trim is it?

Why would you need reset on new battery? :unsure: I'm no expert though 馃槈

Anyway, would suggest do exactly the same now, disconnect it for at least 10 min.

Bear in mind there's separate battery for start/stop feature, it might need recharging or new.

Let us know the outcome of whatever you do
 

Registered
Joined
2 Posts
Discussion Starter #3
Hi, welcome to the forum.

Remember, first rule of this forum is car show of 馃榿 what year/engine/trim is it?

Why would you need reset on new battery? :unsure: I'm no expert though 馃槈

Anyway, would suggest do exactly the same now, disconnect it for at least 10 min.

Bear in mind there's separate battery for start/stop feature, it might need recharging or new.

Let us know the outcome of whatever you do
[/QUOTE

Thanks for getting back to me.
Its an XF, 2016, 2.0 diesel with the R trim.
The Kwik Fit guy said they needed to reset it after installing the new battery, Just went along with it. Didn't realise there was a separate battery for the start/stop.
I'm guessing the second battery maybe at fault.
I read in post that this can only be done at a Jaguar garage, so that's our next step I guess.
Thanks again.
 
1 - 3 of 3 Posts
Top