XF Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Have had my car just under a year now have not had any issues until 2 days ago. So was driving on a country road was on sport mode and using paddle shifters was starting to slow down so turned my dial to D then the car made a few strange noises and stopped. Tried to restart it and didn't sound good seemed like there was not nough battery power, so called a recovery who can and tried to jump start it with a booster pack witch didn't work so then tried with leads eventually got it started but was making a squeaking skreetching sound and engine seemed very out of time and shaky also a gearbox fault came on the display. Switched the car back off at that point tried to start it again but with no luck. Have had the car transported to a local garage but looking to see if anyone has had any issues like this or someone who is technically minded that could give me possible ideas to what this may be. Any advice will be greatly appreciated
 

·
Registered
Joined
·
1 Posts
Mine did something similar with the sounds you described 3.0d - Ended up being the bottom end of the engine had killed itself. Spun main end bearing / snapped crank.
 

·
Registered
Joined
·
257 Posts
I can't add anything as what you describe is way outside my wheelhouse. Do please let us know how you get along.

Mine did something similar with the sounds you described 3.0d - Ended up being the bottom end of the engine had killed itself. Spun main end bearing / snapped crank.
Yikess!!
 
1 - 3 of 3 Posts
Top