XF Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
My heated seats take a while to warm up compared with those on my previous BMW, & once they start to heat up they get quite hot for a while after turning them off. There doesn't seem to be any difference in any of the 3 settings

Anyone else have the same problem?
 

·
Administrator
Joined
·
22,500 Posts
I think mine are the same. I have not been impressed with the warm up time and the ability to reduce what becomes an uncomfortable heat does not seem to work.
Now that you have brought it up I might ask for it to be investigated.
 

·
Registered
Joined
·
319 Posts
No problem with mine, in a very cold morning , put it on full for a couple of minutes , then need to turn down to 1st setting , just right !.
 

·
Administrator
Joined
·
22,500 Posts
sodgob said:
No problem with mine, in a very cold morning , put it on full for a couple of minutes , then need to turn down to 1st setting , just right !.
Do you know, or will you find out please, just how long it takes before you become aware that it is functioning :?: Mine seems to take a good while and to be honest by the time I am concious of the heat I am happy to be without it.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
pekem said:
sodgob said:
No problem with mine, in a very cold morning , put it on full for a couple of minutes , then need to turn down to 1st setting , just right !.
Do you know, or will you find out please, just how long it takes before you become aware that it is functioning :?: Mine seems to take a good while and to be honest by the time I am concious of the heat I am happy to be without it.

Exactly like mine!
 
1 - 5 of 5 Posts
Top