XF Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Last Thursday when it began.
I was driving xf home and engine management light came off and I was unable to turn the car off I removed the batter and the eging was still running. I manage to take out one of the engine management fuses which shut the engine off.. As precaution I left the engine management fuse out over night but oddly my car kept locking itself and the alarm should go off intermittently I took a risk and left my rear car door just slightly open to stop the car from locking which proved successful its now 2am I can sleep
The following day
As I'm not the best with cars I decided to call a gagarage who would come collect the car thst will now not start which I was expecting only problem now no electricity is getting to the car to allow the gear shift to go up great! Car won't go in to netrual to be hoisted on a truck
Bring on Saturday
Given I had no other choice I paid for a truck with a proper lift to take the car to garage costly! Given the garage closed at 12:30 by the time my car got there it had shut.
Monday car was seen late and they said battery was dead and needed replacing to complete their testing paid await to find out results following day
Tuesday
By some flook they get the car to start by holding the the door unlock botton and the break pedal? Has anyone heard of this?
Advised issue was the start botton and thst the center consol will need to be replaced £790 from jaguar joy I decide it best to fix it now rather than fix it later I go collect the car as the part won't be avaliable for few days. As I pull up I notice my car alarm going off I asked about and they said it keeps doing it they don't know why I think when the manager heard this he sent someone out to check who resolved the issue.
Iv brought the car home and noticed again the alarm going off. Reading on Google I found out you can disable it from central which I did walking away with cheeky grin thinking my perils are coming to end the alarm goes again!. I also read online sometimes it helps to drive it following this advise I started using the unlock botton and as soon a went to pull off everything cut out!. I'll phone the garage in the morning but I love to knopw if anyone has anything similar to this and if they do please can they advise because I'm lost. Just to add further I'm currently sat in the car and their random lightning like flash every now and then but like blue light all around the car and then a weird clunking noise like scratching or gnawing even though I now its not animal or at least I'm sure it isn't
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
blimey...never heard of it. so battery was changed? did they put correct one? looks like still issues with battery
Yeah the original battery was compldlety dead even though it is under it life time expectancy. They replaced it with new one which cost a couple of hundred quid so I'm kinda confident its the right one
 

·
Registered
Joined
·
267 Posts
I'd want to know more from the garage before giving the OK to order a £790 part. How did they come to the conclusion it was this that's at fault and why would this give the symptoms you've described.
Is the garage a Jaguar specialist?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I'd want to know more from the garage before giving the OK to order a £790 part. How did they come to the conclusion it was this that's at fault and why would this give the symptoms you've described.
Is the garage a Jaguar specialist?
They did a diagnostic and the perment fault pointed there I'm not good with cars and due to circumstances I wasn't able to get it into jaguar speclist though they are very reputal gagarage
 

·
Registered
Joined
·
267 Posts
This is a difficult one for me. My spidey senses are saying "take it to a Jag specialist or main dealer".
On the other hand, if the garage comes recommended by a reliable third party, maybe give them a go.
If it were me, what action I took would come down to budget. If you can afford it let a specialist take a look to be on the safe side, if not, go with what ya got.
 

·
Registered
Joined
·
1 Posts
I have recently had similar problems.... random hazards turning on, wouldn't stop, overhead lights coming on, no instrument lights and wouldn't turn over, all in various combinations and at random. I tried disconnecting batteries and earthing the leads out....no good. I replaced both batteries and key fob battery....still playing up! Took everything out of the spare wheel well and found small amounts of water. Took off cover of rear fuse box and found water droplets. Unplugged fuse box to reveal unit behind.... water droplets. Rear wiring loom cloth tape wet through. Dried surplus water and then left a fan heater and hair dryer running to dry everything. All is now as it should be and running fine.

I suspect the rear offside vent seal to be the culprit but it has been too cold for me to investigate that. Another lockdown job for warmer weather.

In conclusion it costs nothing to eliminate the damp problem before expensive battery replacement.
XF Sportbrake 2.2d 2014

IMG_20210202_140114232.jpg
IMG_20210202_140114232.jpg
 

Attachments

·
Registered
XFS sportbrake portfolio 3 let V6
Joined
·
18 Posts
Last Thursday when it began.
I was driving xf home and engine management light came off and I was unable to turn the car off I removed the batter and the eging was still running. I manage to take out one of the engine management fuses which shut the engine off.. As precaution I left the engine management fuse out over night but oddly my car kept locking itself and the alarm should go off intermittently I took a risk and left my rear car door just slightly open to stop the car from locking which proved successful its now 2am I can sleep
The following day
As I'm not the best with cars I decided to call a gagarage who would come collect the car thst will now not start which I was expecting only problem now no electricity is getting to the car to allow the gear shift to go up great! Car won't go in to netrual to be hoisted on a truck
Bring on Saturday
Given I had no other choice I paid for a truck with a proper lift to take the car to garage costly! Given the garage closed at 12:30 by the time my car got there it had shut.
Monday car was seen late and they said battery was dead and needed replacing to complete their testing paid await to find out results following day
Tuesday
By some flook they get the car to start by holding the the door unlock botton and the break pedal? Has anyone heard of this?
Advised issue was the start botton and thst the center consol will need to be replaced £790 from jaguar joy I decide it best to fix it now rather than fix it later I go collect the car as the part won't be avaliable for few days. As I pull up I notice my car alarm going off I asked about and they said it keeps doing it they don't know why I think when the manager heard this he sent someone out to check who resolved the issue.
Iv brought the car home and noticed again the alarm going off. Reading on Google I found out you can disable it from central which I did walking away with cheeky grin thinking my perils are coming to end the alarm goes again!. I also read online sometimes it helps to drive it following this advise I started using the unlock botton and as soon a went to pull off everything cut out!. I'll phone the garage in the morning but I love to knopw if anyone has anything similar to this and if they do please can they advise because I'm lost. Just to add further I'm currently sat in the car and their random lightning like flash every now and then but like blue light all around the car and then a weird clunking noise like scratching or gnawing even though I now its not animal or at least I'm sure it isn't
 

·
Registered
XFS sportbrake portfolio 3 let V6
Joined
·
18 Posts
As JGLS has intimated I would be looking at water ingress
not the same car but same stable,our Discovery 3 started acting very strange on holiday in Cornwall last July
alarm would go off for no reason , thought it was just a glitch ,fast forward to September it did it again along with the door locks all bouncing it was locking unlocking its self.
we also had other odd electrical issues .
I traced it to a well documented corroded wire splice where 4 wires come into 1 in the loom ,the loom ran along the passenger door footwell that as any D 3 owner will tell us a pond
worth looking for water in possible ingress points mate
 
1 - 11 of 11 Posts
Top