XF Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi guys, my left rear abs sensor cable got severed by debris on the road, howevere at the same time the fuel gquge has now said ive no fuel left. The question is this, Is the fuel level sensors covered by a fuse? If so where is it?
Many thanks
Paul
Xf 2010 3.0 v6 diesel s
 

·
Registered
Joined
·
116 Posts
I had an abs sensor fail and it seemed to throw my fuel consumption readings out, presumably because the car could not measure the speed etc, so I agree with the above, fix the abs issue and the fuel gauge may well go back to normal.
 
  • Like
Reactions: Pigzymarsh

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
it was the connections in the diesel tank to the fuel level sensors. Swallows Racing Jaguar rewired them with the tank in situ. bloody car went into a crazy misfire though and they also said that was induced. it kept stalling so i had to be recovered back home.
thanks all.
massive thanks to Swallows.
if you ever need help... they are the only crew youll ever need!!
 

·
Registered
Joined
·
116 Posts
Sorry, don't really understand. What do you (they) mean by 'induced'? Is the car fully fixed and up and running now?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
i got towed home first by the aa that failed to diagnose, from 200 miles away from home. swallows diagnosed and sorted it in hour and half. the misfire was purposeful because the car was reading empty. all sported and back to full powrr now
 

·
Registered
Joined
·
116 Posts
Good news, glad you got it all sorted (y)
 
1 - 9 of 9 Posts
Top